aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-09-29 16:47:48 +0200
committerThomas White <taw@physics.org>2021-09-29 16:47:48 +0200
commit151629cd57e7047683bfce48b393f6e21da9b90d (patch)
treee0019c35761cfe0687675d3b1125bd776a46d294 /libcrystfel/meson.build
parent9438abb00b495f28c5b2c306fe4d391f6a44acc9 (diff)
Fix Doxygen version numbers
This also removes Doxygen from the CMake build system. It doesn't seem worth trying to make it work both ways. Fixes: https://gitlab.desy.de/thomas.white/crystfel/-/issues/48
Diffstat (limited to 'libcrystfel/meson.build')
-rw-r--r--libcrystfel/meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/libcrystfel/meson.build b/libcrystfel/meson.build
index 968e58a3..05c80473 100644
--- a/libcrystfel/meson.build
+++ b/libcrystfel/meson.build
@@ -174,8 +174,8 @@ install_headers(['src/reflist.h',
doxygen = find_program('doxygen', required: false)
if doxygen.found()
- index_md = files('doc/index.md')
- coding_md = files('doc/coding.md')
+ vers = vcs_tag(input: 'doc/Doxyfile-version.in',
+ output: 'Doxyfile-version')
doc_data = configuration_data()
doc_data.set('DOX_TOP', join_paths(meson.current_source_dir(), 'src'))
@@ -183,13 +183,16 @@ if doxygen.found()
doc_data.set('CODING_MD', join_paths(meson.current_source_dir(), 'doc/coding.md'))
doc_data.set('OUTPUT_DIR', join_paths(meson.current_build_dir(), 'docs'))
doc_data.set('VERSION', meson.project_version())
+ doc_data.set('API_REVISION', libcrystfel_api_version)
doxyfile = configure_file(input: 'doc/Doxyfile.in',
output: 'Doxyfile',
configuration: doc_data,
install: false)
- api_docs = run_target('api-docs', command: [doxygen, doxyfile])
+ api_docs = run_target('api-docs',
+ command: [doxygen, doxyfile],
+ depends: vers)
endif