aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-03-15 16:53:09 +0100
committerThomas White <taw@physics.org>2021-03-16 13:59:36 +0100
commitb8ebe9370c6d7df3e2c71665881608bf519276eb (patch)
tree9a2aa8da90a7820fab3e98c769802afada08e12a /libcrystfel/meson.build
parent88c41a8e26b31d86d6116cc5bc220e34bcb92ec1 (diff)
Move MTZ and XDS export to libcrystfel
Diffstat (limited to 'libcrystfel/meson.build')
-rw-r--r--libcrystfel/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/libcrystfel/meson.build b/libcrystfel/meson.build
index 8b8eb77d..38b8002d 100644
--- a/libcrystfel/meson.build
+++ b/libcrystfel/meson.build
@@ -32,6 +32,11 @@ if fdipdep.found()
conf_data.set10('HAVE_FDIP', 1)
endif
+ccp4dep = dependency('libccp4c', required: false)
+if ccp4dep.found()
+ conf_data.set10('HAVE_LIBCCP4', 1)
+endif
+
libcrystfel_versionc = vcs_tag(input: 'src/libcrystfel-version.c.in',
output: 'libcrystfel-version.c')
@@ -122,7 +127,8 @@ libcrystfel = library('crystfel', [libcrystfel_sources, libcrystfel_versionc],
include_directories : [libcrystfel_includes, libcrystfel_conf_inc],
dependencies : [mdep, utildep, fftwdep, gsldep, zlibdep,
hdf5dep, pthreaddep, ncursesdep,
- xgandalfdep, pinkindexerdep, fdipdep],
+ xgandalfdep, pinkindexerdep, fdipdep,
+ ccp4dep],
install : true)
libcrystfeldep = declare_dependency(include_directories : libcrystfel_includes,