aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2014-01-07 20:48:25 +0000
committerThomas White <taw@bitwiz.org.uk>2014-01-07 20:48:25 +0000
commit115e8fbfe3af0e0556a58b34b2a52c79536628e0 (patch)
treeae48b10e2791f87d936fb09f8d4dd61b82a8eaeb /Makefile.am
parenta7fc324e125fbbdd062172bbf37777c9b8d1d97b (diff)
Initial work for new SC processor
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 11b29c5..3269346 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ EXTRA_DIST = configure m4/gnulib-cache.m4
SUBDIRS = lib harfatum
ACLOCAL_AMFLAGS = -I m4
-bin_PROGRAMS = src/colloquium
+bin_PROGRAMS =
AM_CFLAGS = -Wall
AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib \
@@ -12,15 +12,15 @@ LDADD = $(top_builddir)/lib/libgnu.la @IGNORE_UNUSED_LIBRARIES_CFLAGS@ \
src_colloquium_SOURCES = src/colloquium.c src/render.c \
src/mainwindow.c src/presentation.c \
- src/loadsave.c src/frame.c \
- src/slideshow.c src/wrap.c src/storycode.c \
+ src/frame.c src/sc_parse.c \
+ src/slideshow.c src/wrap.c src/sc_interp.c \
src/imagestore.c src/notes.c src/pr_clock.c \
src/inhibit_screensaver.c src/slide_sorter.c
INCLUDES = -Iharfatum/src
EXTRA_DIST += src/presentation.h src/render.h src/wrap.h \
- src/loadsave.h src/slideshow.h src/storycode.h \
+ src/slideshow.h src/sc_parse.h src/sc_interp.h \
src/imagestore.h src/notes.h src/pr_clock.h \
src/inhibit_screensaver.h src/slide_sorter.h
@@ -39,16 +39,17 @@ desktopdir = $(datadir)/applications
desktop_DATA = colloquium.desktop
EXTRA_DIST += $(desktop_DATA)
-noinst_PROGRAMS = tests/storycode_test tests/render_test tests/render_test_sc1
+noinst_PROGRAMS = tests/storycode_test
+#tests/render_test tests/render_test_sc1
TESTS = tests/storycode_test tests/render_test tests/render_test_sc1
-tests_storycode_test_SOURCES = tests/storycode_test.c src/storycode.c
+tests_storycode_test_SOURCES = tests/storycode_test.c src/sc_parse.c
tests_render_test_SOURCES = tests/render_test.c src/render.c src/frame.c \
- src/wrap.c src/storycode.c src/imagestore.c \
+ src/wrap.c src/sc_parse.c src/imagestore.c \
src/loadsave.c
-tests_render_test_sc1_SOURCES = tests/render_test_sc1.c src/storycode.c \
+tests_render_test_sc1_SOURCES = tests/render_test_sc1.c src/sc_parse.c \
src/render.c src/frame.c src/wrap.c \
src/imagestore.c \
src/loadsave.c