aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2013-03-05 22:23:59 +0100
committerThomas White <taw@bitwiz.org.uk>2013-03-05 22:23:59 +0100
commitb7930391bf1981b68227bb1c286cd28630cfd544 (patch)
treea29808407cbce6187fdafb43e41a15c4b62deba6 /Makefile.am
parentb447e47da5e2bb6c0450506af9491741cc6f3340 (diff)
Move "libstorycode" back to this repository
Keeping it separate, just for the sake of "harfatum", was causing a lot more awkwardness than it could ever solve, compared to just duplicating the code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ee669c..d80325f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
EXTRA_DIST = configure m4/gnulib-cache.m4
-SUBDIRS = lib libstorycode harfatum
+SUBDIRS = lib harfatum
ACLOCAL_AMFLAGS = -I m4
bin_PROGRAMS = src/colloquium
@@ -8,17 +8,17 @@ AM_CFLAGS = -Wall
AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib \
-I$(top_srcdir)/lib
LDADD = $(top_builddir)/lib/libgnu.la @IGNORE_UNUSED_LIBRARIES_CFLAGS@ \
- libstorycode/src/libstorycode.la harfatum/src/libharfatum.la
+ harfatum/src/libharfatum.la
src_colloquium_SOURCES = src/colloquium.c src/render.c \
src/mainwindow.c src/presentation.c \
src/stylesheet.c src/loadsave.c src/frame.c \
- src/slideshow.c src/wrap.c
+ src/slideshow.c src/wrap.c src/storycode.c
-INCLUDES = -Ilibstorycode/src -Iharfatum/src
+INCLUDES = -Iharfatum/src
EXTRA_DIST += src/presentation.h src/render.h src/wrap.h \
- src/stylesheet.h src/loadsave.h src/slideshow.h
+ src/stylesheet.h src/loadsave.h src/slideshow.h src/storycode.h
colloquiumdir = $(datadir)/colloquium
colloquium_DATA = data/colloquium.ui
@@ -33,7 +33,7 @@ noinst_PROGRAMS = tests/render_test tests/render_test_sc1
TESTS = tests/render_test tests/render_test_sc1
tests_render_test_SOURCES = tests/render_test.c src/render.c src/frame.c \
- src/wrap.c
+ src/wrap.c src/storycode.c
-tests_render_test_sc1_SOURCES = tests/render_test_sc1.c \
+tests_render_test_sc1_SOURCES = tests/render_test_sc1.c src/storycode.c \
src/render.c src/frame.c src/wrap.c