aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2013-05-23 23:28:49 +0200
committerThomas White <taw@bitwiz.org.uk>2013-05-23 23:28:49 +0200
commitc11f7f9735c0573b3ff5a073e8ae6014933660cd (patch)
treeba808115b8c68cfdb9a3ba7feea38ba66202c5da /Makefile.am
parent050c29036e59a340f27de7bb80ce7dd2aacb212e (diff)
Default stylesheet stuff
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1bc1f29..9171abb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ AM_CFLAGS = -Wall
AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib \
-I$(top_srcdir)/lib
LDADD = $(top_builddir)/lib/libgnu.la @IGNORE_UNUSED_LIBRARIES_CFLAGS@ \
- harfatum/src/libharfatum.la
+ harfatum/src/libharfatum.la src/default_stylesheet.o
src_colloquium_SOURCES = src/colloquium.c src/render.c \
src/mainwindow.c src/presentation.c \
@@ -22,6 +22,9 @@ EXTRA_DIST += src/presentation.h src/render.h src/wrap.h \
src/stylesheet.h src/loadsave.h src/slideshow.h src/storycode.h \
src/imagestore.h
+src/default_stylesheet.o: src/default_stylesheet.sty
+ ld -r -b binary -o src/default_stylesheet.o src/default_stylesheet.sty
+
colloquiumdir = $(datadir)/colloquium
colloquium_DATA = data/colloquium.ui