aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2014-01-12 22:20:07 +0100
committerThomas White <taw@bitwiz.org.uk>2014-01-12 22:20:07 +0100
commite0cfd1748e891548cadab2500447e2e944d08600 (patch)
tree1d1b1babf4fb5e91dfbf66fc3559b2aefb3ea1cb /Makefile.am
parentd66704db5091ec97d57a6939ecef8f33fb1aac76 (diff)
Most of the new interpreter structure
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 3269346..56e0298 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,14 +15,15 @@ src_colloquium_SOURCES = src/colloquium.c src/render.c \
src/frame.c src/sc_parse.c \
src/slideshow.c src/wrap.c src/sc_interp.c \
src/imagestore.c src/notes.c src/pr_clock.c \
- src/inhibit_screensaver.c src/slide_sorter.c
+ src/inhibit_screensaver.c src/slide_sorter.c \
+ src/shape.c
INCLUDES = -Iharfatum/src
EXTRA_DIST += src/presentation.h src/render.h src/wrap.h \
src/slideshow.h src/sc_parse.h src/sc_interp.h \
src/imagestore.h src/notes.h src/pr_clock.h \
- src/inhibit_screensaver.h src/slide_sorter.h
+ src/inhibit_screensaver.h src/slide_sorter.h src/shape.h
src/default_stylesheet.o: src/default_stylesheet.sty
ld -r -b binary -o src/default_stylesheet.o src/default_stylesheet.sty
@@ -39,15 +40,15 @@ desktopdir = $(datadir)/applications
desktop_DATA = colloquium.desktop
EXTRA_DIST += $(desktop_DATA)
-noinst_PROGRAMS = tests/storycode_test
-#tests/render_test tests/render_test_sc1
+noinst_PROGRAMS = tests/storycode_test tests/render_test
+#tests/render_test_sc1
TESTS = tests/storycode_test tests/render_test tests/render_test_sc1
tests_storycode_test_SOURCES = tests/storycode_test.c src/sc_parse.c
tests_render_test_SOURCES = tests/render_test.c src/render.c src/frame.c \
src/wrap.c src/sc_parse.c src/imagestore.c \
- src/loadsave.c
+ src/sc_interp.c src/shape.c
tests_render_test_sc1_SOURCES = tests/render_test_sc1.c src/sc_parse.c \
src/render.c src/frame.c src/wrap.c \