aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-03-10 14:09:23 +0100
committerThomas White <taw@physics.org>2018-03-10 17:50:22 +0100
commitf60b18e91d983b3bc6ad3b9dcd02c26c2afed685 (patch)
treeb45b78453fe728b0d712ef75cffea62bef885e3e /Makefile.am
parent2af0de620328c13e8dc9997bc95e694321409d96 (diff)
Remove autotools
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am51
1 files changed, 0 insertions, 51 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index 446fb91..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,51 +0,0 @@
-EXTRA_DIST = configure m4/gnulib-cache.m4
-SUBDIRS = lib
-ACLOCAL_AMFLAGS = -I m4
-
-bin_PROGRAMS = src/colloquium
-
-AM_CFLAGS = -Wall
-AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib \
- -I$(top_srcdir)/lib
-LDADD = $(top_builddir)/lib/libgnu.la @IGNORE_UNUSED_LIBRARIES_CFLAGS@
-
-src_colloquium_SOURCES = src/colloquium.c src/render.c \
- src/presentation.c \
- src/frame.c src/sc_parse.c \
- src/slideshow.c src/sc_interp.c \
- src/imagestore.c src/pr_clock.c \
- src/sc_editor.c src/narrative_window.c \
- src/slide_window.c src/testcard.c src/print.c \
- src/debugger.c
-
-EXTRA_DIST += src/presentation.h src/render.h \
- src/slideshow.h src/sc_parse.h src/sc_interp.h \
- src/imagestore.h src/pr_clock.h \
- src/print.h \
- src/sc_editor.h src/slide_window.h src/narrative_window.h \
- src/print.h src/debugger.h
-
-colloquiumdir = $(datadir)/colloquium
-colloquium_DATA = data/sky.png data/canvas.png data/demo.sc
-EXTRA_DIST += $(colloquium_DATA)
-
-iconsdir = $(datadir)/icons/hicolor/scalable/apps
-icons_DATA = data/colloquium.svg
-EXTRA_DIST += $(icons_DATA)
-
-desktopdir = $(datadir)/applications
-desktop_DATA = colloquium.desktop
-EXTRA_DIST += $(desktop_DATA)
-
-noinst_PROGRAMS = tests/storycode_test tests/render_test tests/render_test_sc1
-TESTS = tests/storycode_test tests/render_test tests/render_test_sc1
-
-tests_storycode_test_SOURCES = tests/storycode_test.c src/sc_parse.c
-
-tests_render_test_SOURCES = tests/render_test.c src/render.c src/frame.c \
- src/sc_parse.c src/imagestore.c \
- src/sc_interp.c
-
-tests_render_test_sc1_SOURCES = tests/render_test_sc1.c src/sc_parse.c \
- src/render.c src/frame.c \
- src/imagestore.c src/sc_interp.c