summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..97fd6cd
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,18 @@
+# Meson file for GlitchyClock
+project('glitchyclock', 'c',
+ version : '0.1.0',
+ license : 'GPL3+',
+ default_options : ['buildtype=debugoptimized'])
+
+# Dependencies
+cc = meson.get_compiler('c')
+mdep = cc.find_library('m', required : false)
+gtk_dep = dependency('gtk+-3.0', required : true)
+cairo_dep = dependency('cairo', required : true)
+
+# Main program
+executable('glitchyclock',
+ ['glitchyclock.c',
+ ],
+ dependencies : [gtk_dep, mdep],
+ install : true)