aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2008-06-12 23:22:26 -0700
committerDave Airlie <airlied@linux.ie>2008-10-17 06:38:57 +1000
commit6df7b0719fe92b718e486c2b87e2f883cfa41efa (patch)
treec0a48d61bf6dd496d2ecaee2adc1eb111f40466e /configure.ac
parent26076bf24a4e720e389d0a3ea616a8350397fdfc (diff)
intel: Protect bufmgr objects with a pthread mutex.
We want to be able to use the bufmgr from multiple threads for GL, and thus we need to protect the internal structures. The pthread-stubs package is used so that programs not linked against pthreads get weak symbols to stubs and don't eat most of the cost.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0cf09744..92507cb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,10 @@ AC_PROG_CC
AC_HEADER_STDC
AC_SYS_LARGEFILE
+PKG_CHECK_MODULES(PTHREADSTUBS, pthread-stubs)
+AC_SUBST(PTHREADSTUBS_CFLAGS)
+AC_SUBST(PTHREADSTUBS_LIBS)
+
pkgconfigdir=${libdir}/pkgconfig
AC_SUBST(pkgconfigdir)
AC_ARG_ENABLE(udev, AS_HELP_STRING([--enable-udev],