aboutsummaryrefslogtreecommitdiff
path: root/libdrm/Makefile.am
diff options
context:
space:
mode:
authorJesse Barnes <jbarnes@virtuousgeek.org>2008-12-17 10:09:49 -0800
committerJesse Barnes <jbarnes@virtuousgeek.org>2008-12-17 10:11:37 -0800
commit731cd5526e5c732d51307b26e784f454a724a699 (patch)
tree215249e4aa86a3d8418b7f5cad95551d49ecce2d /libdrm/Makefile.am
parentc86d431fe6174b1c2de531929213ea7dbd92326d (diff)
libdrm: add mode setting files
Add mode setting files to libdrm, including xf86drmMode.* and the new drm_mode.h header. Also add a couple of tests to sanity check the kernel interfaces and update code to support them.
Diffstat (limited to 'libdrm/Makefile.am')
-rw-r--r--libdrm/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libdrm/Makefile.am b/libdrm/Makefile.am
index a5be36e0..eb63abe1 100644
--- a/libdrm/Makefile.am
+++ b/libdrm/Makefile.am
@@ -26,9 +26,10 @@ libdrm_la_LDFLAGS = -version-number 2:4:0 -no-undefined
AM_CFLAGS = -I$(top_srcdir)/shared-core
libdrm_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c \
+ xf86drmMode.c libdrm_lists.h
libdrm_lists.h
libdrmincludedir = ${includedir}
-libdrminclude_HEADERS = xf86drm.h
+libdrminclude_HEADERS = xf86drm.h xf86drmMode.h
EXTRA_DIST = ChangeLog TODO