aboutsummaryrefslogtreecommitdiff
path: root/libdrm/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-10-03 22:56:04 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2009-10-03 22:58:25 +0100
commitab3300c5816ee26e2d74ac99e2d84c3dfd7cdf82 (patch)
treec4f9ba3602ece092aa991463d8ba027aa9a4c6f3 /libdrm/Makefile.am
parent61bddf8504461fad3e45fbf0d32956a76e0dd343 (diff)
intel: Add a configure option to *disable* building libdrm-intel
In conjunction with the atomic operation patch, it may be more convenient for some people to disable building libdrm-intel and its dependencies upon the atomic intrinsics then it is for them to use a supported compiler. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'libdrm/Makefile.am')
-rw-r--r--libdrm/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/libdrm/Makefile.am b/libdrm/Makefile.am
index 0c07220f..d13bead7 100644
--- a/libdrm/Makefile.am
+++ b/libdrm/Makefile.am
@@ -18,6 +18,10 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+if HAVE_INTEL
+INTEL_SUBDIR = intel
+endif
+
if HAVE_NOUVEAU
NOUVEAU_SUBDIR = nouveau
endif
@@ -26,7 +30,7 @@ if HAVE_RADEON
RADEON_SUBDIR = radeon
endif
-SUBDIRS = . intel $(NOUVEAU_SUBDIR) $(RADEON_SUBDIR)
+SUBDIRS = . $(INTEL_SUBDIR) $(NOUVEAU_SUBDIR) $(RADEON_SUBDIR)
libdrm_la_LTLIBRARIES = libdrm.la
libdrm_ladir = $(libdir)