aboutsummaryrefslogtreecommitdiff
path: root/libdrm/Makefile.am
diff options
context:
space:
mode:
authorJesse Barnes <jbarnes@virtuousgeek.org>2009-01-07 10:18:08 -0800
committerJesse Barnes <jbarnes@virtuousgeek.org>2009-01-07 10:18:08 -0800
commitf4f76a6894b40abd77f0ffbf52972127608b9bca (patch)
tree0be1812ebe7961b026339d2de8e9c69e6c224725 /libdrm/Makefile.am
parenta8c548034e38d7fb8afeca100230818b3cfcb9d9 (diff)
libdrm: add timeout handling to drmWaitVBlank
In some cases, vblank interrupts may be disabled or otherwise broken. The kernel has a 3s timeout builtin to handle these cases, but the X server's SIGALM for cursor handling may interrupt vblank wait ioctls, causing libdrm to restart the ioctl, making the kernel's timeout useless. This change tracks time across ioctl restarts and returns EBUSY to the caller if the expected vblank sequence doesn't occur within 1s of the first call. Fixes fdo bz #18041, which is caused by a drmWaitVBlank hanging due to the corresponding pipe getting disabled (thus preventing further events from coming in).
Diffstat (limited to 'libdrm/Makefile.am')
-rw-r--r--libdrm/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libdrm/Makefile.am b/libdrm/Makefile.am
index eb63abe1..71a87186 100644
--- a/libdrm/Makefile.am
+++ b/libdrm/Makefile.am
@@ -23,6 +23,7 @@ SUBDIRS = . intel
libdrm_la_LTLIBRARIES = libdrm.la
libdrm_ladir = $(libdir)
libdrm_la_LDFLAGS = -version-number 2:4:0 -no-undefined
+libdrm_la_LIBADD = -lrt
AM_CFLAGS = -I$(top_srcdir)/shared-core
libdrm_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c \