aboutsummaryrefslogtreecommitdiff
path: root/libdrm/intel/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-10-02 04:39:22 +0100
committerEric Anholt <eric@anholt.net>2009-10-02 13:21:23 -0700
commit04495eeec2f053be17a10cc82e646a1e23ed3830 (patch)
treeb4d4ff65046b0cba5712ed07f0deb0b7e6b6133e /libdrm/intel/Makefile.am
parent0fb215ae3199b5be0c9a9474e5941f8d8998c11a (diff)
intel: Use atomic refcounters
As the target architecture for Intel GPUs is the x86, we can presume to have reasonable compiler support for Intel atomic intrinsics, i.e. gcc, and so use those in preference to pulling in a complicated mess of fragile assembly. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> [anholt: hand-resolved against my previous commit. This brings cairo-gl firefox-talos-gfx time from 65 seconds back down to 62 seconds.] Signed-off-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'libdrm/intel/Makefile.am')
-rw-r--r--libdrm/intel/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libdrm/intel/Makefile.am b/libdrm/intel/Makefile.am
index e68a3b46..28f8952b 100644
--- a/libdrm/intel/Makefile.am
+++ b/libdrm/intel/Makefile.am
@@ -35,6 +35,7 @@ libdrm_intel_la_LDFLAGS = -version-number 1:0:0 -no-undefined
libdrm_intel_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@ @CLOCK_LIB@
libdrm_intel_la_SOURCES = \
+ intel_atomic.h \
intel_bufmgr.c \
intel_bufmgr_priv.h \
intel_bufmgr_fake.c \