aboutsummaryrefslogtreecommitdiff
path: root/libdrm/intel/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2008-06-12 23:22:26 -0700
committerEric Anholt <eric@anholt.net>2008-10-09 12:57:09 -0700
commit3169d9639bd002b43e4064cea32e0d262076c1e0 (patch)
tree60a825635a24cf2c3e2dfd759126aab7dd330cf2 /libdrm/intel/Makefile.am
parent604759d4a78efcef0abdb40bfc215526cdcf1122 (diff)
intel: Protect bufmgr objects with a pthread mutex.
We want to be able to use the bufmgr from multiple threads for GL, and thus we need to protect the internal structures. The pthread-stubs package is used so that programs not linked against pthreads get weak symbols to stubs and don't eat most of the cost.
Diffstat (limited to 'libdrm/intel/Makefile.am')
-rw-r--r--libdrm/intel/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libdrm/intel/Makefile.am b/libdrm/intel/Makefile.am
index 607c4765..92388c24 100644
--- a/libdrm/intel/Makefile.am
+++ b/libdrm/intel/Makefile.am
@@ -26,6 +26,7 @@ AM_CFLAGS = \
$(WARN_CFLAGS) \
-I$(top_srcdir)/libdrm \
-I$(top_srcdir)/libdrm/intel \
+ $(PTHREADSTUBS_CFLAGS) \
-I$(top_srcdir)/shared-core
libdrm_intel_la_LTLIBRARIES = libdrm_intel.la