aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7efc4d4e..9d2a69dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,11 @@ AC_ARG_ENABLE(radeon-experimental-api,
[Enable support for radeon's KMS API (default: disabled)]),
[RADEON=$enableval], [RADEON=no])
+AC_ARG_ENABLE(glamo-experimental-api,
+ AS_HELP_STRING([--enable-glamo-experimental-api],
+ [Enable support for Glamo's KMS API (default: disabled)]),
+ [GLAMO=$enableval], [GLAMO=no])
+
dnl ===========================================================================
dnl check compiler flags
AC_DEFUN([LIBDRM_CC_TRY_FLAG], [
@@ -138,6 +143,8 @@ AM_CONDITIONAL(HAVE_NOUVEAU, [test "x$NOUVEAU" = xyes])
AM_CONDITIONAL(HAVE_RADEON, [test "x$RADEON" = xyes])
+AM_CONDITIONAL(HAVE_GLAMO, [test "x$GLAMO" = xyes])
+
PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
if test "x$HAVE_CAIRO" = xyes; then
AC_DEFINE(HAVE_CAIRO, 1, [Have cairo support])
@@ -198,6 +205,8 @@ AC_OUTPUT([
libdrm/radeon/libdrm_radeon.pc
libdrm/nouveau/Makefile
libdrm/nouveau/libdrm_nouveau.pc
+ libdrm/glamo/Makefile
+ libdrm/glamo/libdrm_glamo.pc
shared-core/Makefile
tests/Makefile
tests/modeprint/Makefile