aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-11-17 07:12:59 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-11-17 07:12:59 +0000
commitcb0f123ef7a2d83796a648baa14e93ed00c639d6 (patch)
treeb13de4e2b471f7ec086d88f7b7ce51d5d126dbff /configure.in
parentc21b3e1d1c8635bdeb9ead64d5616621cd2fa451 (diff)
implemented spell checking.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@754 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9056aec1..3d49dba0 100644
--- a/configure.in
+++ b/configure.in
@@ -248,6 +248,26 @@ if test "$ac_cv_enable_compface" = yes; then
AC_CHECK_LIB(compface, uncompface,,[ac_cv_enable_compface=no])
fi
+dnl Check for GtkSpell support
+AC_MSG_CHECKING([whether to use GtkSpell])
+AC_ARG_ENABLE(gtkspell,
+ [ --enable-gtkspell Use GtkSpell in editor [[default=no]]],
+ [ac_cv_enable_gtkspell=$enableval], [ac_cv_enable_gtkspell=no])
+if test "$ac_cv_enable_gtkspell" = yes; then
+ AC_MSG_RESULT(yes)
+ AC_MSG_CHECKING([whether GtkSpell is available])
+ if $PKG_CONFIG gtkspell-2.0 ; then
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS `$PKG_CONFIG --cflags gtkspell-2.0`"
+ LIBS="$LIBS `$PKG_CONFIG --libs gtkspell-2.0`"
+ AC_DEFINE(USE_GTKSPELL, 1, Use GtkSpell in editor)
+ else
+ AC_MSG_RESULT(no)
+ fi
+else
+ AC_MSG_RESULT(no)
+fi
+
AC_CHECK_LIB(xpg4, setlocale)
dnl for GThread support (currently disabled)
@@ -371,6 +391,7 @@ echo "OpenSSL : $ac_cv_enable_ssl"
echo "iconv : $am_cv_func_iconv"
echo "compface : $ac_cv_enable_compface"
echo "IPv6 : $ac_cv_enable_ipv6"
+echo "GtkSpell : $ac_cv_enable_gtkspell"
echo ""
echo "The binary will be installed in $prefix/bin"
echo ""