aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2006-08-03 06:52:37 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2006-08-03 06:52:37 +0000
commit34165083a911ffb9bf2c6938e3466285d553cfd8 (patch)
tree84794a347e85611b44fab93d07adb95735303d58 /configure.in
parent5e8ab5643ca4752d53f4363d21bbc2b7b6518aef (diff)
support Oniguruma for regex.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@1113 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 29 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 83c565f6..b2318332 100644
--- a/configure.in
+++ b/configure.in
@@ -9,7 +9,7 @@ MINOR_VERSION=2
MICRO_VERSION=7
INTERFACE_AGE=0
BINARY_AGE=0
-EXTRA_VERSION=
+EXTRA_VERSION=+svn
VERSION=$MAJOR_VERSION.$MINOR_VERSION.$MICRO_VERSION$EXTRA_VERSION
dnl set $target
@@ -269,6 +269,33 @@ else
AC_MSG_RESULT(no)
fi
+dnl Check for Oniguruma support in message filtering
+AC_ARG_ENABLE(oniguruma,
+ [ --enable-oniguruma Use Oniguruma instead of system's regex [[default=no]]],
+ [ac_cv_enable_oniguruma=$enableval], [ac_cv_enable_oniguruma=no])
+AC_MSG_CHECKING([whether to use Oniguruma])
+if test "$ac_cv_enable_oniguruma" = yes; then
+ AC_MSG_RESULT(yes)
+ AC_CHECK_HEADERS(oniguruma.h onigposix.h,
+ [ AC_DEFINE(USE_ONIGURUMA, 1, Define if you want to use Oniguruma.) ],
+ [ ac_cv_enable_oniguruma=no ])
+
+ if test "$ac_cv_enable_oniguruma" = yes; then
+ AC_CHECK_LIB(onig, onig_new,
+ [ ac_cv_enable_oniguruma=yes ],
+ [ ac_cv_enable_oniguruma=no ])
+ fi
+
+ AC_MSG_CHECKING([whether oniguruma is available])
+ AC_MSG_RESULT($ac_cv_enable_oniguruma)
+
+ if test "$ac_cv_enable_oniguruma" = yes; then
+ LIBS="$LIBS -lonig"
+ fi
+else
+ AC_MSG_RESULT(no)
+fi
+
AC_CHECK_LIB(xpg4, setlocale)
dnl for GThread support (currently disabled)
@@ -404,6 +431,7 @@ echo "iconv : $am_cv_func_iconv"
echo "compface : $ac_cv_enable_compface"
echo "IPv6 : $ac_cv_enable_ipv6"
echo "GtkSpell : $ac_cv_enable_gtkspell"
+echo "Oniguruma : $ac_cv_enable_oniguruma"
echo ""
echo "The binary will be installed in $prefix/bin"
echo ""