aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-09-15 08:08:00 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-09-15 08:08:00 +0000
commitebd74af9cc2cee5758ba3ee65817ea002f32f8cc (patch)
treeede14bc507cbd77733c1ecc9a0ae497f8097773b /configure.in
parent9ba0a1333e12add2d5b8cadbfd4d440fedb7ad90 (diff)
use $DATADIRNAME for $localedir if it is defined.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@585 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index cb988984..3af13764 100644
--- a/configure.in
+++ b/configure.in
@@ -91,7 +91,12 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Define text domain.])
AM_GLIB_GNU_GETTEXT
dnl AM_GNU_GETTEXT
dnl AC_CHECK_FUNC(gettext, AC_CHECK_LIB(intl, gettext))
-localedir='${datadir}/locale'
+
+if test "x$DATADIRNAME" != "x"; then
+ localedir='${prefix}/${DATADIRNAME}/locale'
+else
+ localedir='${datadir}/locale'
+fi
AC_ARG_WITH(localedir,
[ --with-localedir=DIR Locale directory],
[localedir="$withval"])