aboutsummaryrefslogtreecommitdiff
path: root/plugin/test/Makefile.am
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2009-06-10 08:11:08 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2009-06-10 08:11:08 +0000
commitca06cd994b09cbb500b35af30c8bd75dc3e0e5b7 (patch)
tree3474db42cb4b1c42007cfb84ec24ca8331b50dba /plugin/test/Makefile.am
parent81f0f7394f9c47a30314f2884be6d4bdae302673 (diff)
merged plugin-test branch into trunk.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@2164 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'plugin/test/Makefile.am')
-rw-r--r--plugin/test/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/plugin/test/Makefile.am b/plugin/test/Makefile.am
new file mode 100644
index 00000000..f7ec8ef7
--- /dev/null
+++ b/plugin/test/Makefile.am
@@ -0,0 +1,18 @@
+libdir = $(plugindir)
+
+lib_LTLIBRARIES = test.la
+
+test_la_SOURCES = test.c test.h
+test_la_LDFLAGS = -module -no-undefined -avoid-version
+
+INCLUDES = \
+ $(GTK_CFLAGS) \
+ -I$(includedir) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/libsylph \
+ -I$(top_srcdir)/src
+
+test_la_LIBADD = \
+ $(GTK_LIBS) \
+ $(top_srcdir)/src/libsylpheed-plugin-0.la \
+ $(top_srcdir)/libsylph/libsylph-0.la