summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2023-04-22 22:03:19 +0200
committerThomas White <taw@physics.org>2023-04-23 09:01:10 +0200
commiteefca3c5bcb7faa8bbb402e982f040d4ac8ea91f (patch)
treec56e6cb0005801ab92701635206762b0465c985b /meson.build
Initial import
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..98a2788
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,13 @@
+project('x1k2-midi-osc', ['c'],
+ version: '0.1.0',
+ license: 'GPL3+',
+ default_options: ['buildtype=debugoptimized'])
+
+# Dependencies
+lo_dep = dependency('liblo', required: true)
+alsa_dep = dependency('alsa', required: true)
+
+executable('x1k2-midi-osc',
+ ['x1k2-midi-osc.c'],
+ dependencies: [lo_dep, alsa_dep],
+ install: true)