aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2009-07-17 12:46:27 +0100
committerThomas White <taw@bitwiz.org.uk>2009-07-17 12:46:27 +0100
commit9ae0abe3414ea26f83fe3e01a37c3cd4819a82b9 (patch)
treed9e87a4b4bc035132a7e93b71c97ba90f257faec /src/Makefile.am
Initial import
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..5578b7b
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,9 @@
+bin_PROGRAMS = tuxmessenger
+tuxmessenger_SOURCES = about.c listcache.c mainwindow.c msnprotocol.c sbprotocol.c \
+ addcontact.c contactlist.c listcleanup.c messagewindow.c options.c sbsessions.c twnauth.c \
+ error.c main.c msngenerics.c routines.c statusicons.c avatars.c mime.c xml.c \
+ msnp2p.c msninvite.c accountwindow.c prefswindow.c blockwindow.c reversewindow.c ink.c \
+ msnp11chl.c gtk-ink.c fonttrans.c filetrans.c
+tuxmessenger_LDADD = @LIBS@ @GTK_LIBS@ @XML_LIBS@
+AM_CFLAGS = -Wall -g @CFLAGS@ @GTK_CFLAGS@ @XML_CPPFLAGS@
+AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\"