aboutsummaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.me.uk>2018-10-17 10:18:44 +0200
committerThomas White <taw@bitwiz.me.uk>2018-10-17 10:18:44 +0200
commit28bc23c38f2d8f88667671b5b78a79f22e56e6b0 (patch)
tree5bfcb2f250f86a04e5bef6d40581c779bb46dab2 /tests/meson.build
parent791ee4e65f3ec7ef470302e4381baefb431fb56d (diff)
Add JSON stylesheet test
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 427faae..c919e35 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -13,3 +13,7 @@ test('Simple rendering', e)
e = executable('render_test_sc1', 'render_test_sc1.c', basic_rendering,
dependencies : [gtkdep, mdep])
test('Simple StoryCode rendering', e)
+
+e = executable('json_test', 'json_test.c', '../src/sc_parse.c',
+ dependencies : [mdep, jsondep])
+test('JSON parsing', e)