aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-03-13 10:25:25 +0100
committerThomas White <taw@physics.org>2018-03-13 10:26:44 +0100
commit01559859c7bc12fd942927af44b0f46eb55dc918 (patch)
tree1d79fb794c91c393d1734c055102b0c87216e3db /CMakeLists.txt
parentb75e8edb86ea416ddd0c3e944dddcfdb2be38fc9 (diff)
Add libcrystfel subdir after everything else is set up
Otherwise loads of flags and dependencies are missing.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 81cad49e..3401a6be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,9 +49,6 @@ set(COMMON_LIBRARIES
)
-# Add the libcrystfel target
-add_subdirectory(libcrystfel)
-
include(GetGitRevisionDescription)
get_git_head_revision(GIT_REFSPEC GIT_SHA1)
@@ -79,6 +76,9 @@ check_library_exists(rt clock_gettime "time.h" HAVE_CLOCK_GETTIME)
configure_file(config.h.cmake.in config.h)
include_directories(${CMAKE_CURRENT_BINARY_DIR})
+# Add the libcrystfel target
+add_subdirectory(libcrystfel)
+
# ----------------------------------------------------------------------
# Build Target
# partial_sim