aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-03-13 09:51:11 +0100
committerThomas White <taw@physics.org>2018-03-13 09:51:11 +0100
commit279ae2e0836a91f8bff0a225ceaf733d4e072aa7 (patch)
tree1f4d6e7a6bc09993f938086e49c7f98a6689680d /CMakeLists.txt
parent94c6d3db4d024e8ebfe82070a9763aff769bbac8 (diff)
Enable colour diagnostics
This is a hack. It should be disabled sometimes, e.g. if not compiling on a terminal.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15576448..4b5717b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,7 @@ find_package(FDIP)
find_package(OpenCL)
include(config)
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fdiagnostics-color=always")
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
add_definitions(-DHAVE_CONFIG_H -DDATADIR=\"${CMAKE_INSTALL_FULL_DATADIR}\")