aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-05-30 14:53:19 +0200
committerThomas White <taw@physics.org>2018-05-30 14:53:19 +0200
commit920829b23cd590ddfa15a849e9ccb7adb5024490 (patch)
tree19cbd1eafdb331a448c0ce42c199d0f9c8589e7f /CMakeLists.txt
parentc1f97c02f7cbd5b8f6264e1b6624658b7631fe5c (diff)
Reduce over-linking
Only two CrystFEL programs actually use HDF5 directly
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2dbf2877..8bb37e05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,7 @@ set(CMAKE_C_STANDARD 99)
# Common include directories and libraries
set(COMMON_INCLUDES ${HDF5_INCLUDE_DIRS})
-set(COMMON_LIBRARIES libcrystfel ${HDF5_C_LIBRARIES} Threads::Threads GSL::gsl)
+set(COMMON_LIBRARIES libcrystfel m GSL::gsl Threads::Threads)
include(GetGitRevisionDescription)
get_git_head_revision(GIT_REFSPEC GIT_SHA1)
@@ -109,7 +109,7 @@ endif(HAVE_OPENCL)
add_executable(pattern_sim ${PATTERN_SIM_SOURCES} ${PATTERN_SIM_OPENCL_SOURCES})
target_include_directories(pattern_sim PRIVATE ${COMMON_INCLUDES})
-target_link_libraries(pattern_sim ${COMMON_LIBRARIES})
+target_link_libraries(pattern_sim ${COMMON_LIBRARIES} ${HDF5_C_LIBRARIES})
if(HAVE_OPENCL)
target_include_directories(pattern_sim PRIVATE ${OpenCL_INCLUDE_DIRS})
@@ -246,7 +246,7 @@ list(APPEND CRYSTFEL_EXECUTABLES partialator)
set(AMBIGATOR_SOURCES src/ambigator.c)
add_executable(ambigator ${AMBIGATOR_SOURCES})
target_include_directories(ambigator PRIVATE ${COMMON_INCLUDES})
-target_link_libraries(ambigator ${COMMON_LIBRARIES})
+target_link_libraries(ambigator ${COMMON_LIBRARIES} ${HDF5_C_LIBRARIES})
list(APPEND CRYSTFEL_EXECUTABLES ambigator)
# ----------------------------------------------------------------------