aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-04-01 17:50:52 +0200
committerThomas White <taw@physics.org>2012-02-22 15:27:23 +0100
commitee02a33acba401edb89d0abf5b4f52be79fe603b (patch)
tree38fe45478ef54ebbeb6c4dd8cb54c6953b5cfa66 /Makefile.am
parent9950ce6e9f76476e7d63c8b553e6877fa774c7ab (diff)
Add unit test for peak integration
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index db6d1286..3d6949ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,10 +7,11 @@ bin_PROGRAMS = src/pattern_sim src/process_hkl src/get_hkl src/indexamajig \
src/calibrate_detector src/partialator \
src/check_hkl src/sum_stack
-noinst_PROGRAMS = tests/list_check
+noinst_PROGRAMS = tests/list_check tests/integration_check
TESTS = tests/list_check tests/first_merge_check tests/second_merge_check \
- tests/third_merge_check tests/fourth_merge_check
+ tests/third_merge_check tests/fourth_merge_check \
+ tests/integration_check
EXTRA_DIST += tests/first_merge_check tests/second_merge_check \
tests/third_merge_check tests/fourth_merge_check \
@@ -118,6 +119,11 @@ endif
tests_list_check_SOURCES = tests/list_check.c src/reflist.c src/thread-pool.c \
src/utils.c
+tests_integration_check_SOURCES = tests/integration_check.c src/peaks.c \
+ src/reflist.c src/cell.c src/detector.c \
+ src/thread-pool.c src/utils.c src/image.c \
+ src/hdf5-file.c
+
INCLUDES = "-I$(top_srcdir)/data"
EXTRA_DIST += src/cell.h src/hdf5-file.h src/image.h src/utils.h \