aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2011-02-07 17:30:20 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:13 +0100
commitb53f133381ef6ffa9f7ecefbf4d134d55ad94455 (patch)
tree8d74e647af300185d71f47c1746ef62cd635005b /Makefile.am
parent58addb645ea760b701feb489a7efe4500082a591 (diff)
Add unit test for reflist
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 81cc91a5..0761af9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,10 @@ bin_PROGRAMS = src/pattern_sim src/process_hkl src/get_hkl src/indexamajig \
src/calibrate_detector src/partialator src/reintegrate \
src/estimate_background src/check_hkl
+noinst_PROGRAMS = tests/list_check
+
+TESTS = tests/list_check
+
if HAVE_GTK
bin_PROGRAMS += src/hdfsee
endif
@@ -98,6 +102,8 @@ src_reintegrate_SOURCES = src/reintegrate.c src/cell.c src/hdf5-file.c \
src_estimate_background_SOURCES = src/estimate_background.c src/stream.c \
src/utils.c src/cell.c src/thread-pool.c
+tests_list_check_SOURCES = tests/list_check.c src/reflist.c
+
INCLUDES = "-I$(top_srcdir)/data"
EXTRA_DIST += src/cell.h src/hdf5-file.h src/image.h src/utils.h \