aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2013-09-05 16:30:45 +0200
committerThomas White <taw@physics.org>2013-09-05 16:30:45 +0200
commit76720a263a298d00652dcce0f12f5be60ec8bc9d (patch)
treee5f1ebfbd6ff4ef2611c2ae9cc2336f49230465a /configure.ac
parentd836294be9879418c1b8290ca9cf6df3dc58eadc (diff)
configure: check for curses, and compile even if it's not available
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4793b291..e5a2a976 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,6 +261,8 @@ PKG_CHECK_MODULES([FFTW], [fftw3],
have_fftw=false
])
+AX_WITH_CURSES
+
dnl Conditionals...
AM_CONDITIONAL([HAVE_OPENCL], test x$have_opencl = xtrue)
@@ -295,7 +297,7 @@ MAIN_LIBS="$MAIN_LIBS $GDK_pixbuf_2_LIBS $TIMER_LIBS $FFTW_LIBS"
MAIN_LIBS="$MAIN_LIBS $Pango_LIBS $PangoCairo_LIBS $LDFLAGS"
AC_SUBST([MAIN_LIBS])
-LIBCRYSTFEL_LIBS="$LIBS $HDF5_LIBS $GSL_LIBS $FFTW_LIBS $LDFLAGS"
+LIBCRYSTFEL_LIBS="$LIBS $HDF5_LIBS $GSL_LIBS $FFTW_LIBS $CURSES_LIB $LDFLAGS"
AC_SUBST([LIBCRYSTFEL_LIBS])
GTK_DOC_CHECK([1.9],[--flavour no-tmpl])