aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2009-12-15 05:54:51 -0800
committerThomas White <taw@bitwiz.org.uk>2009-12-16 01:54:12 -0800
commita97808a51b9e15df23307115ca889e01c604c0dc (patch)
tree67c6987fe5f561616d17a548beeb0b05714c2204 /configure.ac
parent4d4aa2f6e2a98461d022d6ce494c58b04b586711 (diff)
Introduce 'hdfsee'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e5c8383d..1005c613 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,13 @@ AC_ARG_WITH(hdf5,
HDF5_LIBS="-L$withval/lib -lhdf5"],
[HDF5_LIBS="-lhdf5"])
-CFLAGS="$CFLAGS $HDF5_CFLAGS"
-LIBS="$LIBS $HDF5_LIBS -lm -lz -lgsl -lgslcblas"
+havegtk=false
+AM_PATH_GTK_2_0(2.0.0, havegtk=true,
+AC_MSG_WARN([GTK not found. hdfsee will not be built.]))
-AC_OUTPUT(Makefile src/Makefile)
+AM_CONDITIONAL([HAVE_GTK], test x$havegtk = xtrue)
+
+CFLAGS="$CFLAGS $HDF5_CFLAGS $GTK_CFLAGS"
+LIBS="$LIBS $HDF5_LIBS -lm -lz -lgsl -lgslcblas $GTK_LIBS -lgthread-2.0"
+
+AC_OUTPUT(Makefile src/Makefile data/Makefile)