aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-07-29 16:07:16 +0200
committerThomas White <taw@physics.org>2012-02-22 15:27:35 +0100
commitbca7a90bc0bb8e5aecbbdd946e950bcaa24f1c77 (patch)
tree23e914f4e512c3b8fd6aeb66192c409eab4a6855 /configure.ac
parentd7ee0d1aff5be156ba5f71d03d7591f364a2aa04 (diff)
More ReAx stuff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1b7ccb70..01a89553 100644
--- a/configure.ac
+++ b/configure.ac
@@ -230,6 +230,18 @@ AC_CHECK_LIB([rt], [clock_gettime],
])
+AC_CHECK_LIB([fftw3], [fftw_plan_dft_r2c_1d],
+[
+ AC_DEFINE([HAVE_FFTW], [1],
+ [Define to 1 if FFTW is available.])
+ FFTW_LIBS="-lfftw3"
+ have_fftw=true
+], [
+ AC_MSG_WARN([ReAx indexing will not be available.])
+ have_fftw=false
+])
+
+
dnl Conditionals...
AM_CONDITIONAL([HAVE_OPENCL], test x$have_opencl = xtrue)
@@ -242,6 +254,7 @@ AM_CONDITIONAL([BUILD_CUBEIT], test x$have_cairo = xtrue \
AM_CONDITIONAL([HAVE_CAIRO], test x$have_cairo = xtrue)
+AM_CONDITIONAL([HAVE_FFTW], test x$have_fftw = xtrue)
gl_IGNORE_UNUSED_LIBRARIES
@@ -252,7 +265,7 @@ CFLAGS="$CFLAGS $GDK_pixbuf_CFLAGS $GDK_pixbuf_2_CFLAGS"
LIBS="$LIBS $HDF5_LIBS -lm -lz $GSL_LIBS $GTK_LIBS $OPENCL_LIBS -pthread"
LIBS="$LIBS $LIBTIFF_LIBS $libPNG_LIBS $Cairo_LIBS $GDK_pixbuf_LIBS"
-LIBS="$LIBS $GDK_pixbuf_2_LIBS $TIMER_LIBS $LDFLAGS"
+LIBS="$LIBS $GDK_pixbuf_2_LIBS $TIMER_LIBS $FFTW_LIBS $LDFLAGS"
GTK_DOC_CHECK([1.11],[--flavour no-tmpl])