aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2010-12-07 19:20:44 -0700
committerThomas White <taw@physics.org>2012-02-22 15:27:08 +0100
commitc2a85bc44e4883b6240d0b5debfa6f1ed8bce915 (patch)
tree03e00afa820a234e41fd8ede0337d0da4b0f6872 /configure.ac
parent5084f60ed55119d709cfd7f75fcc5823f58bc094 (diff)
Add Gnulib to deal with unportability of 'strndup'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5a862aed..4d77d8be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,10 +7,14 @@ VERSION=AC_PACKAGE_VERSION
AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(crystfel, "$VERSION")
+AC_CONFIG_FILES(lib/Makefile)
+
AC_PROG_CC
+gl_EARLY
AC_PROG_AWK
AC_PROG_INSTALL
AC_PROG_LN_S
+AC_PROG_RANLIB
AC_HEADER_STDC
@@ -20,6 +24,10 @@ AC_FUNC_MALLOC
AC_TYPE_SIGNAL
AC_CHECK_FUNCS([strdup strndup])
+gl_INIT
+
+gl_FUNC_STRNDUP
+
AC_ARG_WITH(hdf5,
[AS_HELP_STRING([--with-hdf5], [specify location of HDF5 library])],