aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2016-10-17 17:29:16 +0200
committerThomas White <taw@physics.org>2016-10-17 17:37:10 +0200
commit22951c51e383e8a2f1a01d8bca60e4da9732633c (patch)
tree8a7f092115f473e06e53dfa5e307b7320c5c603e /libcrystfel/Makefile.am
parentcc55abcff6e91d57e8226fa8a4265b667c20ceb0 (diff)
Initial TakeTwo import
Only changes from Helen's code so far: 1. Stripping trailing spaces 2. Tweaking includes (<> -> "") 3. Adding initial CrystFEL hooks at the bottom of taketwo.c 4. Moving definition of struct SpotVec to taketwo.c 5. Removing prototype for run_taketwo from taketwo.h (comment moved to .c) 6. Authorship/copyright boilerplate
Diffstat (limited to 'libcrystfel/Makefile.am')
-rw-r--r--libcrystfel/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libcrystfel/Makefile.am b/libcrystfel/Makefile.am
index d7142f6a..7bb08685 100644
--- a/libcrystfel/Makefile.am
+++ b/libcrystfel/Makefile.am
@@ -10,7 +10,8 @@ libcrystfel_la_SOURCES = src/reflist.c src/utils.c src/cell.c src/detector.c \
src/render.c src/index.c src/dirax.c src/mosflm.c \
src/cell-utils.c src/integer_matrix.c src/crystal.c \
src/xds.c src/integration.c src/predict-refine.c \
- src/histogram.c src/events.c src/felix.c
+ src/histogram.c src/events.c src/felix.c \
+ src/taketwo.c
if HAVE_FFTW
libcrystfel_la_SOURCES += src/asdf.c
@@ -30,7 +31,8 @@ libcrystfel_la_include_HEADERS = ${top_srcdir}/version.h \
src/integer_matrix.h src/crystal.h \
src/xds.h src/predict-refine.h \
src/integration.h src/histogram.h \
- src/events.h src/asdf.h src/felix.h
+ src/events.h src/asdf.h src/felix.h \
+ src/taketwo.h
AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib -Wall
AM_CPPFLAGS += -I$(top_srcdir)/lib @LIBCRYSTFEL_CFLAGS@