aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-11-15 12:17:59 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:40 +0100
commit469efb904b59f137ac9e85e5ff23edd0c113de5c (patch)
tree71fab5f5715ec9f88984450cdabb592cd49dd46d /libcrystfel/Makefile.am
parent38089071300b8e04ed42236dd08d9055094fb3b8 (diff)
Move a load more stuff into libcrystfel
Diffstat (limited to 'libcrystfel/Makefile.am')
-rw-r--r--libcrystfel/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/libcrystfel/Makefile.am b/libcrystfel/Makefile.am
index daf2ef33..304eb7bb 100644
--- a/libcrystfel/Makefile.am
+++ b/libcrystfel/Makefile.am
@@ -1,5 +1,11 @@
lib_LTLIBRARIES = libcrystfel.la
libcrystfel_la_SOURCES = src/reflist.c src/utils.c src/cell.c src/detector.c \
src/thread-pool.c src/image.c src/hdf5-file.c \
- src/beam-parameters.c
+ src/beam-parameters.c src/geometry.c src/statistics.c \
+ src/symmetry.c src/stream.c src/peaks.c \
+ src/reflist-utils.c src/filters.c src/diffraction.c \
+ src/diffraction-gpu.c src/cl-utils.c
+
INCLUDES = "-I$(top_srcdir)/data"
+AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib
+AM_CPPFLAGS += -I$(top_srcdir)/lib