aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-11-15 17:31:09 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:41 +0100
commit4c65ae0588c789e9f15eb1f0c324224301082263 (patch)
tree6d06f339697dc16b8556ac2b4bd8318534497429 /libcrystfel/Makefile.am
parentd3ec66174fbfcb3780e106ca25134fd58a45506c (diff)
Separate CFLAGS and LIBS for libcrystfel and main
Diffstat (limited to 'libcrystfel/Makefile.am')
-rw-r--r--libcrystfel/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libcrystfel/Makefile.am b/libcrystfel/Makefile.am
index e813699b..05532ab8 100644
--- a/libcrystfel/Makefile.am
+++ b/libcrystfel/Makefile.am
@@ -1,5 +1,5 @@
lib_LTLIBRARIES = libcrystfel.la
-LDADD = $(top_builddir)/lib/libgnu.a @IGNORE_UNUSED_LIBRARIES_CFLAGS@
+LDADD = $(top_builddir)/lib/libgnu.a @LIBCRYSTFEL_LIBS@
libcrystfel_la_SOURCES = src/reflist.c src/utils.c src/cell.c src/detector.c \
src/thread-pool.c src/image.c src/hdf5-file.c \
@@ -21,4 +21,4 @@ libcrystfel_la_include_HEADERS = src/beam-parameters.h src/hdf5-file.h \
INCLUDES = "-I$(top_srcdir)/data"
AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib
-AM_CPPFLAGS += -I$(top_srcdir)/lib
+AM_CPPFLAGS += -I$(top_srcdir)/lib @LIBCRYSTFEL_CFLAGS@