aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2012-03-09 18:21:58 +0100
committerThomas White <taw@physics.org>2012-03-09 18:21:58 +0100
commit7236d936e381faf32950f1091aa57f240644ac16 (patch)
treed594eb58c91c55138c84921eaf39654e824145b8 /libcrystfel/Makefile.am
parent4be9287d7ae69bcfee52efed5a108f31c0f40f7e (diff)
Compile libcrystfel with -Wall, fix warnings
Diffstat (limited to 'libcrystfel/Makefile.am')
-rw-r--r--libcrystfel/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libcrystfel/Makefile.am b/libcrystfel/Makefile.am
index a86b7786..d13bbc93 100644
--- a/libcrystfel/Makefile.am
+++ b/libcrystfel/Makefile.am
@@ -25,5 +25,5 @@ libcrystfel_la_include_HEADERS = src/beam-parameters.h src/hdf5-file.h \
src/index-priv.h src/reax.h
INCLUDES = "-I$(top_srcdir)/data"
-AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib
+AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib -Wall
AM_CPPFLAGS += -I$(top_srcdir)/lib @LIBCRYSTFEL_CFLAGS@