aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-11-15 13:59:17 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:40 +0100
commit25c3d29ed7701cadbb3813878f25b633a7cd7c2d (patch)
tree2efd3bd84ee6948543b0bc89053f7654047b8542 /libcrystfel/Makefile.am
parentfb9df2f18def2d0b8fbdbc854c8a8c10e39ce6d9 (diff)
Move indexing and rendering to libcrystfel
Diffstat (limited to 'libcrystfel/Makefile.am')
-rw-r--r--libcrystfel/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libcrystfel/Makefile.am b/libcrystfel/Makefile.am
index 00428a1f..576044a6 100644
--- a/libcrystfel/Makefile.am
+++ b/libcrystfel/Makefile.am
@@ -4,7 +4,8 @@ libcrystfel_la_SOURCES = src/reflist.c src/utils.c src/cell.c src/detector.c \
src/beam-parameters.c src/geometry.c src/statistics.c \
src/symmetry.c src/stream.c src/peaks.c \
src/reflist-utils.c src/filters.c src/diffraction.c \
- src/diffraction-gpu.c src/cl-utils.c
+ src/diffraction-gpu.c src/cl-utils.c src/render.c \
+ src/index.c src/dirax.c src/mosflm.c src/reax.c
libcrystfel_la_includedir=$(includedir)/crystfel/
libcrystfel_la_include_HEADERS = src/beam-parameters.h src/diffraction-gpu.h \
@@ -14,6 +15,7 @@ libcrystfel_la_include_HEADERS = src/beam-parameters.h src/diffraction-gpu.h \
src/cl-utils.h src/filters.h src/list_tmp.h \
src/statistics.h src/utils.h src/detector.h \
src/geometry.h src/peaks.h src/stream.h \
+ src/render.h src/index.h \
../data/defs.h
INCLUDES = "-I$(top_srcdir)/data"