aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-04-27 13:12:09 +0200
committerThomas White <taw@physics.org>2021-04-27 13:18:32 +0200
commitc66781ed4d8beb611a1155be540cffb3df7ce146 (patch)
tree2e1a724e711ed1446bde872bab9761be66fbf7a2 /libcrystfel/meson.build
parent7424f7d7190d221e5dedcdeadc2809ec8166292e (diff)
Rename libcrystfel's config.h to libcrystfel-config.h
This removes the big potential for confusion, which has happened several times (see e.g. 095cbebaf6). It also fixes in-tree builds with CMake (but seriously, always use out-of-tree builds). Fixes #2.
Diffstat (limited to 'libcrystfel/meson.build')
-rw-r--r--libcrystfel/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/libcrystfel/meson.build b/libcrystfel/meson.build
index 3ee9d495..8ed03454 100644
--- a/libcrystfel/meson.build
+++ b/libcrystfel/meson.build
@@ -121,8 +121,8 @@ libcrystfel_sources = ['src/image.c',
symop_parse_ch,
]
-configure_file(input : 'config.h.in',
- output : 'config.h',
+configure_file(input : 'libcrystfel-config.h.meson.in',
+ output : 'libcrystfel-config.h',
configuration : conf_data)
libcrystfel_conf_inc = include_directories('.')