aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2010-02-24 19:05:45 +0100
committerThomas White <taw@physics.org>2010-02-24 19:05:45 +0100
commit8493aedf54b0747c33c9dbdb85c8fdbf15616d02 (patch)
tree791bc266628f6d61aa47abae1d4db3e0bcabc76a /src/Makefile.am
parentb8872a44c8a6dc60d98d992dca992573a28d059b (diff)
indexamajig can use the GPU too
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 963c5373..921208f6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,6 +25,9 @@ indexamajig_SOURCES = indexamajig.c hdf5-file.c utils.c cell.c image.c \
intensities.c peaks.c index.c filters.c \
diffraction.c detector.c sfac.c
indexamajig_LDADD = @LIBS@
+if HAVE_OPENCL
+indexamajig_SOURCES += diffraction-gpu.c cl-utils.c
+endif
if HAVE_GLIB
indexamajig_SOURCES += dirax.c