aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2010-03-03 17:50:15 +0100
committerThomas White <taw@physics.org>2010-03-03 17:50:15 +0100
commit46a7ae42f1261a4aa0882af958ec93cc2e8d9610 (patch)
tree2976d88d9acce410575c32588be3bb1a8d4a91d7 /src/Makefile.am
parent82792fbe72e2de4fa74f6bfc465159d86e59df43 (diff)
Stabilise DirAx stuff, and remove GLib dependency
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3240290a..e696fcbf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,15 +23,12 @@ process_hkl_LDADD = @LIBS@
indexamajig_SOURCES = indexamajig.c hdf5-file.c utils.c cell.c image.c \
intensities.c peaks.c index.c filters.c \
- diffraction.c detector.c sfac.c
+ diffraction.c detector.c sfac.c dirax.c
indexamajig_LDADD = @LIBS@
if HAVE_OPENCL
indexamajig_SOURCES += diffraction-gpu.c cl-utils.c
endif
-if HAVE_GLIB
-indexamajig_SOURCES += dirax.c
-endif
if HAVE_GTK
hdfsee_SOURCES = hdfsee.c displaywindow.c render.c hdf5-file.c utils.c image.c \
@@ -49,8 +46,4 @@ powder_plot_SOURCES = powder_plot.c cell.c utils.c image.c hdf5-file.c \
detector.c
powder_plot_LDADD = @LIBS@
-if HAVE_GLIB
-powder_plot_SOURCES += dirax.c
-endif
-
INCLUDES = "-I$(top_srcdir)/data"