aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2009-12-15 05:54:51 -0800
committerThomas White <taw@bitwiz.org.uk>2009-12-16 01:54:12 -0800
commita97808a51b9e15df23307115ca889e01c604c0dc (patch)
tree67c6987fe5f561616d17a548beeb0b05714c2204 /src/Makefile.am
parent4d4aa2f6e2a98461d022d6ce494c58b04b586711 (diff)
Introduce 'hdfsee'
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 81b52045..758fcc35 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,11 @@
bin_PROGRAMS = pattern_sim process_hkl get_hkl
+if HAVE_GTK
+bin_PROGRAMS += hdfsee
+endif
+
AM_CFLAGS = -Wall
+AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\"
pattern_sim_SOURCES = pattern_sim.c diffraction.c utils.c image.c cell.c \
hdf5-file.c ewald.c detector.c sfac.c intensities.c \
@@ -11,5 +16,10 @@ process_hkl_SOURCES = process_hkl.c sfac.c statistics.c cell.c utils.c \
reflections.c
process_hkl_LDADD = @LIBS@
+if HAVE_GTK
+hdfsee_SOURCES = hdfsee.c displaywindow.c render.c hdf5-file.c
+hdfsee_LDADD = @LIBS@
+endif
+
get_hkl_SOURCES = get_hkl.c sfac.c cell.c utils.c reflections.c
get_hkl_LDADD = @LIBS@