aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-10-29 10:05:24 +0100
committerThomas White <taw@physics.org>2019-03-11 16:49:36 +0100
commit9a3ef1de0b661085a26d9be60bcff9e261783acd (patch)
treeb1861fe26f2bbc0e9642ba8921c5e1f826a92512 /tests/CMakeLists.txt
parent4337cafe052c4ad238c969dfa4cb7c7ac52f5e07 (diff)
Add new rational number library
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 02f3ca02..beb141c3 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -83,3 +83,7 @@ if (HAVE_OPENCL)
add_test(gpu_sim_check gpu_sim_check)
endif (HAVE_OPENCL)
+add_executable(rational_check rational_check.c)
+target_include_directories(rational_check PRIVATE ${COMMON_INCLUDES})
+target_link_libraries(rational_check ${COMMON_LIBRARIES})
+add_test(rational_check rational_check)