aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-08-05 12:10:32 +0200
committerThomas White <taw@physics.org>2020-08-05 13:39:23 +0200
commita7ce7d83d70e747446cb54581216f440b9677954 (patch)
tree38276443f5f2143afedc34ebb004d9d6e684e79b /tests/CMakeLists.txt
parentee5e7f49c4c582651d1c3760f204ac861864c9d5 (diff)
Convert gpu_sim_check to DataTemplate
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 01abe3eb..373187c9 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -68,7 +68,8 @@ if (HAVE_OPENCL)
../src/diffraction-gpu.c ../src/cl-utils.c)
target_include_directories(gpu_sim_check PRIVATE ${COMMON_INCLUDES} ${OpenCL_INCLUDE_DIRS})
target_link_libraries(gpu_sim_check ${COMMON_LIBRARIES} ${OpenCL_LIBRARIES})
- add_test(gpu_sim_check gpu_sim_check)
+ add_test(NAME gpu_sim_check
+ COMMAND gpu_sim_check ${CMAKE_CURRENT_SOURCE_DIR}/gpu_sim_check.geom)
endif (HAVE_OPENCL)
add_executable(rational_check rational_check.c)