aboutsummaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2022-03-01 17:29:59 +0100
committerThomas White <taw@physics.org>2022-03-02 09:46:30 +0100
commit31f03d0a978df94d4336394923d698c1689d7fcf (patch)
tree6f4915b93ddd2da599afe0f25b3135e69c446fc0 /tests/meson.build
parente882d83df17ce283a2084161d5b02c80a10f9a92 (diff)
Add tests/file-wait
This tests that indexamajig --wait-for-file works
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 6f2822b7..9165a666 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -23,6 +23,14 @@ foreach name : partialator_tests
endforeach
+# Test of waiting for files
+test('file-wait',
+ find_program('file-wait'),
+ args : [indexamajig.full_path(),
+ files('wavelength_geom.h5'),
+ files('wavelength_geom1.geom')])
+
+
# Easy unit tests of libcrystfel functions
simple_tests = ['ambi_check',
'cell_check',