aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8b746557..1eac1a93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,13 @@ AC_FUNC_MALLOC
AC_TYPE_SIGNAL
AC_CHECK_FUNCS([strdup])
-LIBS="$LIBS -lhdf5"
+AC_ARG_WITH(hdf5,
+[AS_HELP_STRING([--with-hdf5], [specify location of HDF5 library])],
+[HDF5_CFLAGS="-I$withval/include"
+ HDF5_LIBS="-L$withval/lib -lhdf5"],
+[])
+
+CFLAGS="$CFLAGS $HDF5_CFLAGS"
+LIBS="$LIBS $HDF5_LIBS -lm -lgsl -lgslcblas"
AC_OUTPUT(Makefile src/Makefile)