aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libcrystfel/meson.build')
-rw-r--r--libcrystfel/meson.build31
1 files changed, 29 insertions, 2 deletions
diff --git a/libcrystfel/meson.build b/libcrystfel/meson.build
index fd4edd1b..f5dc15e4 100644
--- a/libcrystfel/meson.build
+++ b/libcrystfel/meson.build
@@ -17,8 +17,34 @@ if ncursesdep.found()
conf_data.set10('HAVE_CURSES', 1)
endif
-# FIXME: Xgandalf, pinkindexer, FDIP
+xgandalfdep = cc.find_library('xgandalf', required: false)
+if xgandalfdep.found() and cc.has_function('IndexerPlain_index',
+ prefix: '#include <xgandalf/adaptions/crystfel/IndexerPlain.h>',
+ dependencies: xgandalfdep)
+ conf_data.set10('HAVE_XGANDALF', 1)
+else
+ xgandalfdep = dependency('', required: false)
+endif
+pinkindexerdep = dependency('', required: false)
+#pinkindexerdep = cc.find_library('pinkIndexer', required: false)
+#if pinkindexerdep.found() and cc.has_function('PinkIndexer_indexPattern',
+# prefix: '#include <pinkIndexer/adaptions/crystfel/PinkIndexer.h>',
+# dependencies: pinkindexerdep)
+# conf_data.set10('HAVE_PINKINDEXER', 1)
+#else
+# pinkindexerdep = dependency('', required: false)
+#endif
+
+fdipdep = dependency('', required: false)
+#fdipdep = cc.find_library('fastDiffractionImageProcessing', required: false)
+#if fdipdep.found() and cc.has_function('allocatePeakList',
+# prefix: '#include <fastDiffractionImageProcessing/peakList.h>',
+# dependencies: fdipdep)
+# conf_data.set10('HAVE_FDIP', 1)
+#else
+# fdipdep = dependency('', required: false)
+#endif
libcrystfel_versionc = vcs_tag(input: 'src/libcrystfel-version.c.in',
output: 'libcrystfel-version.c')
@@ -105,7 +131,8 @@ libcrystfel_conf_inc = include_directories('.')
libcrystfel = library('crystfel', [libcrystfel_sources, libcrystfel_versionc],
include_directories : [libcrystfel_includes, libcrystfel_conf_inc],
dependencies : [mdep, utildep, fftwdep, gsldep, zlibdep,
- hdf5dep, pthreaddep, ncursesdep],
+ hdf5dep, pthreaddep, ncursesdep,
+ xgandalfdep, pinkindexerdep, fdipdep],
install : true)
libcrystfeldep = declare_dependency(include_directories : libcrystfel_includes,