aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index be0f6477..4f97d8ce 100644
--- a/meson.build
+++ b/meson.build
@@ -69,6 +69,11 @@ if zmqdep.found()
conf_data.set10('HAVE_ZMQ', true)
endif
+asapodep = dependency('libasapo-consumer', required: false)
+if asapodep.found()
+ conf_data.set10('HAVE_ASAPO', true)
+endif
+
if cc.has_function('clock_gettime', prefix: '#include <time.h>')
conf_data.set10('HAVE_CLOCK_GETTIME', true)
endif
@@ -167,8 +172,13 @@ if zmqdep.found()
indexamajig_sources += ['src/im-zmq.c']
endif
+if asapodep.found()
+ indexamajig_sources += ['src/im-asapo.c']
+endif
+
indexamajig = executable('indexamajig', indexamajig_sources,
- dependencies: [mdep, libcrystfeldep, gsldep, pthreaddep, zmqdep],
+ dependencies: [mdep, libcrystfeldep, gsldep,
+ pthreaddep, zmqdep, asapodep],
install: true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')