aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index efaf09a8..81b52045 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,10 +1,15 @@
-bin_PROGRAMS = pattern_sim process_hkl
+bin_PROGRAMS = pattern_sim process_hkl get_hkl
AM_CFLAGS = -Wall
pattern_sim_SOURCES = pattern_sim.c diffraction.c utils.c image.c cell.c \
- hdf5-file.c ewald.c detector.c sfac.c intensities.c
+ hdf5-file.c ewald.c detector.c sfac.c intensities.c \
+ reflections.c
pattern_sim_LDADD = @LIBS@
-process_hkl_SOURCES = process_hkl.c sfac.c statistics.c cell.c utils.c
+process_hkl_SOURCES = process_hkl.c sfac.c statistics.c cell.c utils.c \
+ reflections.c
process_hkl_LDADD = @LIBS@
+
+get_hkl_SOURCES = get_hkl.c sfac.c cell.c utils.c reflections.c
+get_hkl_LDADD = @LIBS@