aboutsummaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 5c5f3d4e..5ad19672 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -53,6 +53,14 @@ endforeach
# Less easy unit tests for libcrystfel functions
+exe = executable('stream_read',
+ ['stream_read.c'],
+ dependencies : [libcrystfeldep])
+test_stream = files('test.stream')
+test('stream_read',
+ exe,
+ args: [test_stream])
+
exe = executable('integration_check',
['integration_check.c',
'histogram.c'],