aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Skeggs <skeggsb@gmail.com>2009-02-11 14:18:03 +1000
committerBen Skeggs <skeggsb@gmail.com>2009-02-15 21:51:46 +1000
commit7e5c512104c3ae9b4ddd121f6bbf9464f8d73181 (patch)
treef98deafded81c20407a2cbc71465140884e6a13d /configure.ac
parenteb78c53aa1a980e60c0dd1f2d0d2f04cb9cb2622 (diff)
libdrm: make libdrm_nouveau conditional, disabled by default
libdrm isn't supposed to ship APIs not present in a released kernel.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62d1a292..dbead723 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,10 @@ AC_ARG_ENABLE(udev, AS_HELP_STRING([--enable-udev],
[Enable support for using udev instead of mknod (default: disabled)]),
[UDEV=$enableval], [UDEV=no])
+AC_ARG_ENABLE(nouveau-experimental-api,
+ AS_HELP_STRING([--enable-nouveau-experimental-api],
+ [Enable support for nouveau's experimental API (default: disabled)]),
+ [NOUVEAU=$enableval], [NOUVEAU=no])
dnl ===========================================================================
dnl check compiler flags
@@ -119,6 +123,11 @@ if test "x$UDEV" = xyes; then
AC_DEFINE(UDEV, 1, [Have UDEV support])
fi
+if test "x$NOUVEAU" = xyes; then
+NOUVEAU_SUBDIR="nouveau"
+AC_SUBST(NOUVEAU_SUBDIR)
+fi
+
PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
if test "x$HAVE_CAIRO" = xyes; then
AC_DEFINE(HAVE_CAIRO, 1, [Have cairo support])