aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2010-01-16 19:28:50 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2010-01-16 19:37:06 -0800
commitb1ce1e6bfbb65cca3230762cf99d4c0775561781 (patch)
tree701944f60f771576778e5967ca861e173a5de42e /configure.ac
parentfe7b93fb493b76ade13ad74438acbc4d34d2f3bd (diff)
Add support for Solaris libc atomic operations
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b257ccf6..49e193e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,6 +186,12 @@ if test "x$INTEL" != "xno"; then
AC_CHECK_HEADER([atomic_ops.h], drm_cv_atomic_primitives="libatomic-ops")
fi
+ # atomic functions defined in <atomic.h> & libc on Solaris
+ if test "x$drm_cv_atomic_primitives" = "xnone"; then
+ AC_CHECK_FUNC([atomic_cas_uint],
+ drm_cv_atomic_primitives="Solaris")
+ fi
+
])
if test "x$drm_cv_atomic_primitives" = xIntel; then
AC_DEFINE(HAVE_INTEL_ATOMIC_PRIMITIVES, 1,